Introducción

El Servicio del almacén de claves de Sparx Systems (SSKS) se usa para administrar el uso de las claves de registro emitidas con las licencias flotantes adquiridas para las ediciones Corporativa, Ingeniería de software y negocio, Ingeniería de sistemas, y Ultimate de Enterprise Architect, y para los productos MDG relacionados.

Usando la aplicación del almacén de claves de Sparx Systems, un administrador puede crear un archivo almacén de claves en una ubicación de la red de trabajo que permita licencias con un periodo reserva (definido por el usuario) limitado, para ser asignado a estaciones de trabajo específicas. El almacén de claves también permite que el administrador determine rápidamente que usuario tiene una clave particular, y ver la fecha en la cual expira la clave.

Tenga en cuenta:

Cada estación de trabajo de Enterprise Architect se puede asociar con sólo un almacén de claves a la vez.

Vea también

•

Informe de derechos de autor

•

Acuerdo de licencia del usuario final

•

Soporte

•

Sus comentarios

•

Instalar el servicio del almacén de claves

•

Comenzar/Detener el servicio del almacén de claves

•

Configurar el servicio del almacén de claves

•

Administración del servicio del almacén de claves de Sparx Systems

•

Configurar Enterprise Architect para adquirir claves desde el almacén de claves

•

Registros de actividad

•

Solución de problemas


Informe de derechos de autor

Derechos de autor © 1998-2010 Sparx Systems Pty. Ltd. Todos los derechos reservados

El software contiene información de propiedad de Sparx Systems Pty Ltd. El mismo se provee bajo un acuerdo de licencia que contiene restricciones acerca del uso y declaración y también se protege por la ley de derechos de autor. Se prohíbe la ingeniería inversa del software. Por favor lea el acuerdo de licencia para obtener más detalles.

Debido al desarrollo continuo del producto, esta información puede cambiar sin aviso. La información y la propiedad intelectual contenida aquí es confidencial entre Sparx Systems y el cliente y permanece como propiedad exclusiva de Sparx Systems. Si encuentra algún problema en la documentación, por favor repórtelo a nosotros por escrito. Sparx Systems no garantiza que este documento esté libre de errores. Ninguna parte de esta publicación se puede reproducir, almacenar en un sistema de recuperación, o trasmitir en cualquier forma o por cualquier medio, electrónico, mecánico, fotocopias, registros o de otra manera sin el previo aviso por escrito de Sparx Systems. A los usuarios licenciados se le garantiza el derecho de imprimir una copia del manual de usuario por copia de licencia del software, pero no puede vender, distribuir, o de otra manera disponer de una copia sin el consentimiento escrito de Sparx Systems.

Sparx Systems Pty. Ltd.

7 Curtis St,

Creswick, Victoria 3363,

AUSTRALIA

Teléfono: +61 (3) 5345 1140

Fax: +61 (3) 5345 1104

Email de soporte: soporte@sparxsystems.com.ar

Email de ventas: ventas@sparxsystems.com.ar

Sitio web: www.sparxsystems.com.ar


Acuerdo de licencia del usuario final

Contrato de licencia del usuario final

Servicio del almacén de claves de Sparx Systems (SSKS)

Derechos de autor (C) 1998-2010 Sparx Systems Pty Ltd. Todos los derechos reservados

IMPORTANTE- LEA DETENIDAMENTE: Este contrato de licencia para el usuario final ("CLUF") constituye un acuerdo legal entre USTED como licenciado y SPARX para el PODUCTO DE SOFTWARE anteriormente identificado. Al instalar, copiar, o de otra forma usar el PRODUCTO DE SOFTWARE, USTED se compromete a respetar los términos de este CLUF. Si no está de acuerdo con los términos de este CLUF, devuelva rápidamente el PRODUCTO DE SOFTWARE sin utilizar al lugar de adquisición.

Los derechos de autor en el PRODUCTO DE SOFTWARE y su documentación son propiedad de Sparx Systems Pty Ltd A.C.N 085 034 546. Sujeto a los términos de este CLUF, a USTED se le otorga un derecho no exclusivo por la duración del CLUF para usar el PRODUCTO DE SOFTWARE. USTED no adquiere propiedad de los derechos de autor u otro derecho de propiedad intelectual en ninguna parte del PRODUCTO DE SOFTWARE por virtud de este CLUF.

El uso de este software indica la aceptación de este CLUF y garantía.

DEFINICIONES

En este Acuerdo De Licencia Del Usuario Final, a menos que aparezca la intención contraria:

•

"CLUF" significa contrato de licencia del usuario final.

•

"SPARX" se refiere a Sparx Systems Pty Ltd A.C.N 085 034 546.

•

El "Licenciatario" se refiere a USTED, o a la organización (si existe) en nombre de la cual USTED está haciendo el CLUF.

•

El "PRODUCTO DE SOFTWARE" o "SOFTWARE" se refiere al servicio del almacén de claves de Sparx Systems, que incluye el software de computadora y los medios asociados y el material impreso, y podrá incluir documentación electrónica o en línea.

•

Los "Servicios de Soporte" se refiere al soporte basado en correo electrónico proporcionado por SPARX, incluidos los consejos sobre el uso del Servicio del almacén de claves de Sparx Systems, la investigación de errores y defectos, la reparación de modelos, si y cuando sea apropiado, y el soporte general al producto.

•

Los "Ingenieros de Soporte de Sparx" se refiere a los empleados de Sparx quienes suministran servicios de soporte en línea.

OTORGAMIENTO DE LICENCIA

De acuerdo a los términos de este CLUF, a USTED se le otorgan los siguientes derechos:

a)

Instalar y usar una copia del PRODUCTO DE SOFTWARE o, cualquier versión anterior para el mismo sistema operativo, en una sola computadora. Como usuario principal de la computadora donde se ha instalado el PRODUCTO DE SOFTWARE, USTED puede hacer una segunda copia para su uso exclusivo en una computadora central o portátil.

b)

Guardar o instalar una copia del PRODUCTO DE SOFTWARE en un dispositivo de almacenamiento, tal como un servidor de red, y usarla solo para instalar o ejecutar el PRODUCTO DE SOFTWARE en la red interna. Si USTED desea aumentar el número de usuarios autorizados al acceso simultaneo al PRODUCTO DE SOFTWARE , USTED debe notificar a SPARX y aceptar a pagar una tarifa adicional.

c)

Hacer copias del PRODUCTO DE SOFTWARE para los propósitos de almacenamiento y seguridad.

LIMITACIONES Y DERECHOS ADICIONALES

Por el presente, USTED se compromete a no vender, alquilar, arrendar, traducir, adaptar, variar, modificar, descompilar, desensamblar, realizar ingeniería reversa, crear trabajos derivados de, modificar, otorgar sub.licencia, prestar o distribuir el PRDUCTO DE SOFTWARE de manera indistinta a la expresamente autorizada por el presente CLUF.

USTED, además se compromete a no reproducir o distribuir los códigos de las claves de licencia, a menos que exista un permiso explícito por escrito de parte de SPARX.

CESIÓN

USTED sólo podrá ceder todos sus derechos y obligaciones según este CLUF a otra parte si USTED suministra al beneficiario una copia de este CLUF y toda la otra documentación, incluida la prueba de propiedad. Su licencia entonces se dará por terminada.

TERMINACIÓN

Sin perjudicar cualquier otro derecho, SPARX podrá terminar este CLUF si USTED no cumple con los términos y condiciones. Al terminar USTED o SU representante deberá destruir todas las copias del PRODUCTO DE SOFTWARE y todas sus partes componentes o, si no, devolver o desechar dicho material de la manera indicada por SPARX.

GARANTÍAS Y RESPONSABILIDADES

GARANTÍAS

SPARX garantiza que el PRODUCTO DE SOFTWARE funcionará considerablemente conforme a los materiales escritos acompañantes por un período de noventa (90) días a partir de la fecha del recibo, y que los Servicios de apoyo serán en gran parte tales como se describen en los materiales escritos aplicables suministrados a USTED por parte de Sparx, y que los ingenieros de soporte de SPARX harán todo el esfuerzo comercialmente razonable para resolver cualquier problema relacionado con el PRODUCTO DE SOFTWARE.

EXCLUSIONES

Hasta el punto máximo permitido por la ley, Sparx excluye, a si mismo y a todo proveedor de software integrado en el PORDUCTO DE SOFTWARE, de toda la responsabilidad, gastos, pérdidas, daños y costos, hechos contra o incurridos o sufridos por USTED directa o indirectamente (incluidos sin limitaciones de costos de pérdida, ganancias o datos) que surjan de:

•

SU uso o mal uso del PRODUCTO DE SOFTWARE

•

SU inhabilidad para usar u obtener a acceso al PRODUCTO DE SOFTWARE

•

Negligencia de SPARX o sus empleados, contratantes o agentes, o cualquier otro proveedor de software incorporado en el PRDODUCTO DE SOFWARE, en conexión con el desempeño de las obligaciones de SPARX bajo este CLUF, o

•

la terminación de este CLUF por cualquier parte por cualquier motivo.

LIMITACIÓN

El PRODUCTO DE SOFTWARE y toda la documentación se proporcionan "COMO SON", y se excluyen todas las garantías ya sean explícitas, tácitas, legales u otras, que se relacionen de alguna manera al contenido de este CLUF o a este CLUF en general, incluidas, sin limitaciones, garantías en cuanto a: la calidad, adecuación, comercialización, corrección, precisión, fiabilidad, concordancia con cualquier descripción o muestra, satisfacción de sus o cualquier otra necesidad, uso ininterrumpido, cumplimiento con cualquier legislación relevante y el estar exento de virus o error. Donde cualquier implicación de legislación en este CLUF cualquier término, y esa legislación evita o prohíbe disposiciones en un contrato, excluyendo o modificando dicho término, dicho término se considerará incluido en este CLUF. Sin embargo, la responsabilidad de SPARX por cualquier violación de dicho término debe, si la legislación lo permite, ser limitada, a juicio de SPARX, a una o más de las siguientes opciones luego de la devolución del PRODUCTO DE SOFTWARE y de una copia del recibo:

•

Si la violación está relacionada con el PRODUCTO DE SOFTWARE:

•

el reemplazo del PRODUCTO DE SOFTWARE o la provisión de un PRODUCTO DE SOFTWARE equivalente

•

la reparación del PRODUCTO DE SOFTWARE

•

el pago del costo del reemplazo del PRDUCTO DE SOFTWARE o de la adquisición de un PRODUCTO DE SOFTWARE equivalente, o

•

el pago del costo de la reparación del PRODUCTO DE SOFTWARE.

•

Si la violación está relacionada con los servicios asociados con el PRODUCTO DE SOFTWARE:

•

El suministro de los servicios nuevamente; o

•

El reembolso de los costos del suministro de los servicios nuevamente.

MARCAS REGISTRADAS

Todos los nombres de productos y compañías usados en este CLUF, el PRODUCTO DE SOFTWARE, o la documentación adjunta podrán ser marcas comerciales de sus Propietarios correspondientes. Es la intención de que su uso en este CLUF esté en conformidad con las licencias y directrices respectivas.

Windows®, Windows 98, Windows NT, Windows ME, Windows XP, Windows Vista, Windows 2000 y Windows 2003 Server son marcas registradas de Microsoft®.

LEY VIGENTE

Este contrato debe interpretarse en virtud de las leyes de la comunidad de AUSTRALIA.


Soporte

El soporte técnico para el servicio del almacén de claves de Sparx Systems está disponible para los usuarios registrados. Las respuestas para consultas de soporte se envían por email. Sparx Systems se esfuerza para proveer una respuesta rápida a todas las preguntas e inquietudes relacionadas con el producto.

Los usuarios registrados puede realizar un pedido de soporte, visitando: http://www.sparxsystems.com.ar/registered/reg_support.html.

Un foro de usuario en línea también está disponible para sus preguntas y lectura, en http://www.sparxsystems.com/cgi-bin/yabb/YaBB.cgi.


Sus comentarios

Sparx Systems quiere estar en contacto con lo que los usuarios del servicio de almacén de claves de Sparx Systems requieren para poder cumplir sus tareas eficientemente y efectivamente. Valoramos cualquier sugerencia, información y comentarios que pueda tener acerca de este producto.

Puede acceder a nuestras páginas de comentarios en línea en:

•

http://www.sparxsystems.com.ar/support/bug_report.html y

•

http://www.sparxsystems.com.ar/support/feature_request.html.

Alternativamente, puede contactar a Sparx Systems por email en: soporte@sparxsystems.com.ar.


Instalar el servicio del almacén de claves

Cuando compra un producto de licencia flotante que usa el servicio del almacén de claves de Sparx Systems, recibe un email del equipo de ventas de Sparx Systems que provee:

•

Las instrucciones de instalación para el servicio del almacén de claves

•

La ubicación del instalador del archivo ejecutable (sparxkeystoreservice.exe) para descargar

•

La contraseña que permite que ejecute el instalador.

Si no recibió la contraseña, o ha perdido una contraseña previa, por favor contáctese con el equipo de ventas de Sparx Systems en ventas@sparxsystems.com.ar

Para instalar el servicio del almacén de claves, descargue y ejecute el archivo ejecutable, e ingrese la contraseña.

Tenga en cuenta: usuarios de Windows Vista/7

Por favor asegúrese de que el instalador se ejecute con los permisos de administrador, haciendo clic con el botón derecho en el archivo del instalador SparxKeystoreService.exe y seleccionando la opción Ejecutar como administrador.

Revise el contrato de licencia y la información del documento léame, haciendo clic en el botón Siguiente cuando termina de leer cada documento. Se abre la página Seleccionar características, desde la cual selecciona las características para instalar.

Opción

Descripción

Servicio del almacén de claves de Sparx Systems

Un servicio TCP/IP que expone funciones de administración de claves compartidas a clientes remotos de Enterprise Architect.

Instale esta característica si desea que la máquina anfitrión actúe como un servidor del almacén de claves.

Administrador del almacén de claves

Una aplicación que facilita la administración de un almacén de claves local o remoto (ej. agregar, eliminar, liberar claves).

Instale esta característica si desea administrar almacenes de claves locales o remotos del servicio del almacén de claves de Sparx Systems (o almacenes de claves basados en un archivo anteriores) desde la máquina anfitrión.

Continúe a través de las pantallas de instalación para finalizar la instalación. Si ha instalado la característica Servicio del almacén de claves de Sparx Systems el instalador intenta iniciar el servicio al final del proceso de instalación, usando la configuración por defecto. Para obtener más información acerca de configurar el servicio, por favor vea el tema Configurar el servicio del almacén de claves.


Iniciar/Detener el servicio del almacén de claves

Puede iniciar o detener el servicio del almacén de claves de Sparx Systems a través de la consola de Servicios de Microsoft Windows. Puede acceder a la consola de Servicios a través del Panel de control (bajo las Herramientas administrativas), o ejecutando el comando services.msc desde la línea de comandos.

Localizar la entradaServicio del almacén de claves de Sparx Systems en la consola de Servicios e iniciar, detener o re iniciar a través de los botones de la barra de herramientas o las opciones de menú contextual.


Configurar el servicio del almacén de claves

Cuando inicia, el servicio del almacén de claves de Sparx Systems escanea su directorio de instalación para el archivo keystoreService.config, que contiene una lista de propiedades y valores usados para configurar el servidor. Las propiedades y sus descripciones se proveen debajo.

Propiedad

Descripción

SERVER_PORT

El puerto TCP/IP en cual se configura el servicio para escuchar conexiones entrantes. Por defecto el servicio del almacén de claves está configurado para correr en el puerto 7770.

AUTHMETHOD

El método usado para autentificar a los usuarios del servicio del almacén de claves que se están conectando al servicio. El valor de este método afecta a cómo se interpreta la propiedad AUTHMETHOD_OPTIONS is mencionada debajo.

Valid AUTHMETHOD values are:

•

AM_GLOBALPASSWORD - Los usuarios son autenticados con una contraseña única y global; la contraseña es especificada en la propiedad AUTHMETHOD_OPTIONS y puede ser dejada en blanco.

•

AM_ACTIVEDIRECTORY - Los usuarios son autenticados de acuerdo a su grupo en el Active Directory; el grupo permitido es especificado por un nombre común en la propiedad AUTHMETHOD_OPTIONS por ejemplo:

AUTHMETHOD_OPTIONS=SSKS_USERGROUP

AUTHMETHOD_OPTIONS

El valor de esta propiedad depende del valor especificado en la propiedad AUTHMETHOD (mencionada arriba); por favor vea la descripción de AUTHMETHOD para más detalles.

KEYSTORE_PATH

La ruta al archivo del almacén de claves. Por defecto el servicio está configurado para proteger y desproteger las claves del archivo sskeys.dat , ubicado en el directorio de instalación de la aplicación.

Tenga en cuenta:

El usuario en el cual el servicio está configurado para ejecutarse debe tener permisos de lectura/escritura en el archivo del almacén de claves especificado en el KEYSTORE_PATH. Si el servicio está configurado para ejecutarse cómo el usuario LOCALSYSTEM, generalmente tiene acceso de lectura/escritura en el directorio de instalación.

MINIMUM_EA_BUILD

La compilación mínima de Enterprise Architect que puede utilizar el almacén de claves. Se puede utilizar esta configuración del servidor del almacén de claves para denegar el acceso a versiones antiguas de Enterprise Architect para que no puedan tomar claves de este almacén de claves.

AUDIT_TIME_PERIOD

El período de tiempo (en segundos) para esperar entre los reportes de registro de actividades. Los reportes de auditoría son registrados a nivel INFO.

Para deshabilitar la auditoría, establezca esta propiedad a 0 (cero).

LOG_LEVEL

El nivel de los mensajes que son escritos en el archivo de registro. Los los niveles más altos incluyen los mensajes de los niveles más bajos que los preceden.

Los niveles de registro válidos, de más bajo a más alto, son:

1.

FATAL - Eventos que resultan en la terminación de la ejecución del servicio.

2.

WARNING - Eventos que caen por fuera del alcance de la operación normal del servicio, pero que no son fatales (por ejemplo una contraseña incorrecta provista por un usuario).

3.

REPORT - Eventos generados por el mecanismo interno interno de auditoría del almacén de claves.

4.

INFO - Eventos generados dentro del alcance normal de la operación del servicio (por ejemplo una protección o desprotección de una clave).

5.

SYSTEM - eventos detallados a nivel de sistema (por ejemplo una conexión/desconexión de un cliente, o el inicio del servicio).

LOG_DIRECTORY

La ruta en la que se escribe el archivo de registro.

Tenga en cuenta:

•

Este directorio debe existir al momento de iniciarse el servicio.

•

El usuario en el cual el servicio está configurado para ejecutarse debe tener permisos de lectura/escritura en el archivo del almacén de claves especificado en el LOG_DIRECTORY. Si el servicio está configurado para ejecutarse cómo el usuario LOCALSYSTEM, generalmente tiene acceso de lectura/escritura en el directorio de instalación.

LOG_FILECOUNT

El número de registros que mantiene el servicio.

Los registros son mantenidos en un orden First-In-First-Out (FIFO), se eliminará el registro más antiguo una vez que se haya alcanzado la cantidad indicada en LOG_FILECOUNT.

LOG_FILESIZE

El tamaño (en bytes) que puede tener un archivo de registro antes de que se comiencen a descartar entradas de registro antiguas.

Otras propiedades a nivel del sistema, como la condición de inicio del servicio y la cuenta del usuario del servicio, se pueden configurar a través de la consola del Servicio de Microsoft Windows. (Vea el tema Comenzar/detener servicio del almacén de claves para obtener detalles acerca de como acceder a la consola deServicio.)


Administración del servicio del almacén de claves

La administración de claves compartidas dentro del almacén de claves se realiza a través del Administrador del almacén de claves, que opera a través de la ventana Almacén de claves de Sparx Systems .

Para administrar un almacén de claves remoto, debe primero conectar la aplicación a este y a cualquier otro almacén de claves remoto como sea requerido. El administrador del almacén de claves le permite:

•

Agregar claves compartidas

•

Establecer periodos de reserva para claves compartidas

•

Migrar claves compartidas desde un almacén de claves basado en archivo

•

Liberar claves compartidas

•

Eliminar claves compartidas.


Conectar a un almacén de claves remoto

Para conectarse a un almacén de claves remoto, seleccione la opción Archivo | Vincular a en la ventana Almacén de claves de Sparx Systems. Se abre la ventana Selección del almacén de claves compartido.

(Alternativamente, para mostrar esta ventana haga clic en el icono Vincular a un almacén existente en la barra de herramientas, o haga clic con el botón derecho en el panel Almacenes de claves y seleccione la opción Vincular a.)

Seleccione el botón Servidor del almacén de claves de Sparx para indicar que desea conectarse a un servicio remoto. (La opción Almacén de claves basado en el archivo esta ahí para proveer capacidades hacia atrás con los almacenes de claves basados en un archivo anteriores; vea Migrar claves compartidas desde un almacén de claves basado en un archivo anteriores, debajo.)

En el campo Dirección del servidor, ingrese el URI al servidor del servicio del almacén de claves de Sparx Systems. Si el módulo de autenticación que elige requiere una contraseña, ingrese una en el campo Contraseña .

Para probar la conectividad al servidor con las credenciales que ha ingresado, haga clic en el botón Probar. Si la conexión falla, revise la dirección, contraseña y permisos. Una vez que la conexión es exitosa, haga clic en el botón Aceptar para finalizar la conexión al servidor.

Se abre la ventana Almacén de clave de Sparx Systems con la ruta del almacén de claves remota en el panel Almacenes de claves.


Agregar claves compartidas

Agregar claves compartidas

Para agregar claves compartidas al almacén de claves: en la ventana Almacén de claves de Sparx Systems, seleccione la opción Clave | Agregar. Se abre la ventana Agregar claves .

(Alternativamente, para mostrar esta ventana haga clic en el icono Agregar clave(s) en la barra de herramientas, o haga clic en el panel Claves contenidas en este almacén y seleccione la opción Agregar.)

En el campo de texto, ingrese las claves (proporcionadas por Sparx Systems), una clave por línea. Haga clic en el botón Aceptar para registrarlas en el almacén de claves.


Establecer periodos de reserva para las claves

Establecer períodos de reserva para las claves

El servicio del almacén de claves de Sparx Systems lo ayuda a:

•

Asegurar que el número de personas que usan Enterprise Architect es limitado al número de licencias flotantes que se han adquirido

•

Permitir a las personas que operen Enterprise Architect usando licencias flotantes mientras están desconectados (ej. usando una computadora portátil).

Para alcanzar esto, seleccione el almacén de claves desde la sección de Almacenes de claves de la ventana Servicio del almacén de claves de Sparx Systems y luego seleccione la opción Herramientas | Opciones . Se abre la ventana Opciones.

(Alternativamente, para mostrar esta ventana haga clic en el nombre del almacén de claves en el panel Almacenes de clave y seleccione la opción Opciones.)

Cuando la mayoría de las personas cierran Enterprise Architect estas ya no requieren sus licencias. Por lo tanto no tiene mucho sentido seguir asignando la licencia a un usuario que no está en realidad usando Enterprise Architect.

•

En la ventana de Opciones, seleccione la casilla Auto proteger para que así cualquier licencia en el almacén de claves se retorne automáticamente al almacén de claves cuando el usuario cierra Enterprise Architect. Haga clic en el botón Aceptar para confirmar su selección. Cuando el usuario cierra Enterprise Architect, la clave queda disponible para el siguiente usuario que desee realizar algún trabajo en Enterprise Architect.

Sin embargo, un usuario de una computadora portátil, una vez que haya cerrado Enterprise Architect, puede aún desear usar la licencia fuera del sitio, sin acceso al almacén de claves y de esta manera sin ninguna forma para pedir otra clave. Aún cuando el usuario de una computadora portátil puede poner su máquina en estado de espera o en el modo dehibernar mientras deja a Enterprise Architect ejecutando, existe el riesgo de que la máquina se deba reinicializar. Una vez que Enterprise Architect se reinicie este reportará la falta de una licencia - la licencia ya se ha protegido automáticamente.

•

Para permitir que tales usuarios tengan acceso a Enterprise Architect, podría deseleccionar la casilla Auto proteger para las claves en el almacén de claves. Haga clic en el botón Aceptar para confirmar su selección.

Esto actúa contra el objetivo de tener la casilla activada. De esta manera se aconseja crear dos almacenes de claves, cada uno con una configuración diferente para Auto proteger:

Destino | Auto proteger
Los usuarios móviles que deseen usar Enterprise Architect desde su casa u otras ubicaciones desconectadas. | No seleccionado
Los usuarios fijos que dejan sus computadoras en el trabajo. | Seleccionado

Si un usuario tiene una clave sin protección automática, estos tienen uso de la clave teóricamente por un tiempo ilimitado. Sin embargo, el servicio del almacén de claves de Sparx Systems también permite que un administrador limite el uso configurando un periodo de reserva para las claves en el almacén de claves. El periodo se cuenta como tiempo continuo gastado fuera de la conexión de la red de trabajo al almacén de claves. El periodo de reserva se puede establecer en semanas o días

Por ejemplo, si un usuario tiene una licencia con un periodo de reserva de una semana y está separado de una conexión activa al almacén de claves por más de una semana, no podrá usar Enterprise Architect hasta que obtenga otra clave.

Para establecer el periodo de reserva para las claves en el almacén de claves:

•

En el primer campo La reserva expira expira después de, ingresar el número requerido de unidades; en el segundo campo, haga clic en la flecha despegable y seleccione la unidad - Días o Semanas. Haga clic en el botón Aceptar para confirmar su selección.


Migrar claves compartidas desde un almacén de claves basado en archivo

Migrar claves compartidas desde un almacén de claves basado en un archivo

Puede desear actualizar desde un almacén de claves basado en un archivo anterior y migrar sus claves a un nuevo almacén de claves basado en la red de trabajo. Este proceso elimina efectivamente todas las claves desde el almacén de claves basado en el archivo, dejándolo vacío, y ubica las claves en el almacén de claves basado en la red trabajo.

Para migrar la claves compartidas, seleccione la opciónArchivo | Vincular a en la ventana Almacén de claves de Sparx Systems (o use el icono de la barra de herramientas o la opción de menú) y seleccione la opción Almacén de claves basado en un archivo, luego busque el almacén de claves local y haga clic en el botón Aceptar para conectarlo. La ventana Almacén de claves de Sparx Systems ahora se parece a los siguiente:

En el panel Almacenes compartidos, haga clic en la ruta del almacén de claves basado en un archivo y luego en la opción de menú Archivo | Migrar a. Se abre la ventana Migrar archivo del almacén de claves, con la ruta del archivo del almacén de claves local en el campoOrigen .

(Alternativamente, para mostrar esta ventana haga clic en el icono Migrar almacén de claves en la barra de herramientas, o haga clic en el panel Almacenes de claves y seleccione la opción Migrar a .)

Haga clic en el botón [ ... ] a la derecha del campo Destino y busque el nombre del almacén de claves basado en la red de trabajo en el cual trasferirá las claves compartidas. Haga clic en el botón Aceptar para migrar las claves compartidas desde el almacén de claves basado en el archivo de origen al almacén de claves basado en el servicio de destino.


Liberar claves compartidas

Usualmente no es necesario liberar manualmente una clave compartida de una estación de trabajo, ya que esto sucede automáticamente si:

•

La opción AutoProteger se ha habilitado y se cierran todas la instancias en ejecución de Enterprise Architect en la estación de trabajo

•

La reserva de la clave expira.

Sin embargo, si más usuarios desean acceder a Enterprise Architect y hay alguna anomalía técnica que ha prevenido el retorno de una clave, puede liberar manualmente la clave usando la ventana delAlmacén de claves de Sparx Systems .

Para liberar una clave desde la asociación activa con una estación de trabajo particular, haga clic en la clave en el panel Claves contenidas en este almacén, y luego seleccione la opción Clave | Liberar .

(Alternativamente, haga clic en el icono Liberar clave en la barra de herramientas, o haga clic en el botón derecho en la clave y seleccione la opción Liberar.)


Eliminar claves compartidas

Para eliminar una clave desde el almacén de claves, abra la ventana Almacén de claves de Sparx Systems, haga clic en la tecla en el panel Claves contenidas en este almacén, y luego seleccione la opciónClave | Eliminar.

(Alternativamente, haga clic en el icono Eliminar clave en la barra de herramientas, o haga clic en el botón derecho en la clave y seleccione la opción Eliminar .)


Configurar Enterprise Architect para adquirir claves desde el almacén de claves

Las claves compartidas están disponibles a través de la compra de licencias flotantes para la edición Corporativa de Enterprise Architect versión 4.51 o superior, y también para las ediciones Ingeniería de software y negocio, Ingeniería de sistemas y Ultimate de Enterprise Architect versión 7.5 o superior.

1.

Desde la estación de trabajo, inicie Enterprise Architect y seleccione la opciónAyuda | Registrar y administrar clave(s) de licencias. Se abre la ventana Administración de licencia.

2.

Haga clic en el botón Agregar clave; se abre la ventana Agregar clave de registro.

3.

Seleccione la pestaña Obtener clave compartida.

4.

En los campos Nombre y Compañía, ingrese su nombre de usuario y el nombre de la compañía.

5.

Haga clic en el botón [ ... ] a la izquierda del campo Almacén de claves compartido y busque la ubicación del almacén de claves compartidas en la red de trabajo.

6.

En el campo Seleccionar un producto, seleccione el producto licenciado y luego haga clic en el botón Aceptar.

Si hay claves disponibles, una será asignada a usted y así podrá continuar trabajando en Enterprise Architect.

Si no hay claves disponibles, no puede trabajar en Enterprise Architect y debe esperar hasta que otro cierre Enterprise Architect y libere la clave.


Registros de actividad

La actividad del servicio del almacén de claves de Sparx Systems se registra en el archivo de acuerdo a las opciones especificadas en la configuracióndel almacén de claves. El contenido del registro se parece a lo siguiente:


Solución de problemas

La mejor fuente de la información de solución de problemas se puede encontrar en los archivos de registro del Servicio del almacén de claves de Sparx Systems. La ubicación del archivo de registro y nivel de detalle se configura a través del archivo de configuración. Se recomienda que, para solucionar un problema, la propiedad LOG_LEVEL se establezca en el nivel más alto, SYSTEM, para que así la mayor cantidad de información este disponible para el administrador.

Fallas de inicialización

Error reportado

Causa

No se pudo abrir el almacén de claves en [RutaDelArchivo]. El archivo no existe y no se pudo crear.

El servicio no pudo abrir el archivo del almacén de claves especificado por la propiedad KEYSTORE_PATH en el archivo de configuración.

Asegúrese de que esta ruta existe, y que la cuenta del usuario del Servicio del almacén de claves de Sparx Systems se ejecuta bajo los permisos necesarios para leer y escribir en el archivo.

No se pudo abrir el almacén de claves, no se especifico ningún archivo de almacén de claves.

No se especificó una ruta del archivo en la propiedad en el archivo de configuración.

Ingrese una ruta de archivo en la propiedad de configuración KEYSTORE_PATH donde el usuario en el cual se ejecuta el Servicio del almacén de claves de Sparx Systems pueda leer y escribir.

Archivo del almacén de claves faltante o inválido - no se puede abrir el archivo del almacén de claves con esta versión del servicio o se ha corrompido el archivo.

El archivo del almacén de claves especificado por la propiedad de configuración KEYSTORE_PATH es incompatible con la versión actual del servicio del almacén de claves, o de alguna manera se ha corrompido en el sistema del archivo.

Restablecer el archivo especificado en la propiedad de configuración KEYSTORE_PATH desde una copia de respaldo reciente, o contactar al soporte de Sparx Systems para obtener asistencia.

Se ha movido el archivo con las claves.

El archivo del almacén de claves especificado por la propiedad de configuración KEYSTORE_PATH se bloquea para el número serial del disco duro en el que se ha creado. Si el archivo del almacén de clave se mueve desde este disco duro, el servicio no podrá abrirlo.

Si el archivo del almacén de claves se ha movido, restablezca el archivo a su ubicación inicial. Ciertas configuraciones RAID pueden afectar como el número serial del disco duro se presenta para el servicio del almacén de claves. De esta manera, se recomienda que aloje el archivo del almacén de claves en un disco que no sea RAID, cuando sea posible.

Fallas de desprotección

Error reportado | Causa
No hay más claves disponibles para este producto en el almacén de claves. | Existen claves para este producto; sin embargo, están todas desprotegidas para otros usuarios. Si este error se reporta frecuentemente, considere limitar el uso del producto a en su compañía o comprar más claves para cumplir con la demanda del producto.
El almacén de claves no contiene ninguna clave para este producto. | Este almacén de claves no contiene claves para el producto requerido. Las claves para el producto se pueden haber proporcionado por el almacén de claves en el pasado, pero se han eliminado. Desinstale el producto y retorne cualquier clave compartida en la máquina del cliente.

Fallas de protección

Error reportado

Causa

No se encontró la clave en el almacén de claves.

La clave que se está protegiendo, o bien se ha eliminado desde que se desprotegió, o se desprotegió desde otro almacén de claves.

Asegúrese de que los usuarios retornan cualquier clave compartida al almacén de claves en el que se adquirieron antes de cambiar almacenes.

Fallas de autenticación - Contraseña global

Error reportado

Causa

GlobalPasswordAM::Authenticate() falló debido a una contraseña inválida.

El usuario falló en autenticarse con el almacén de claves, debido a que proporcionaron una contraseña que no coincidió con la contraseña del servidor especificada en la propiedad de configuración AUTHMETHOD_OPTIONS.

Asegúrese de que la contraseña se ingresó correctamente (las contraseñas distinguen entre mayúsculas y minúsculas), de otra manera contáctese con su administrador del servicio del almacén de claves de Sparx Systems para obtener la contraseña correcta.

Fallas de autenticación - Directorio activo

Error reportado

Causa

No se pudo obtener DefaultNamingContext.

El módulo de autenticación del directorio activo falló al iniciar ya que no pudo resolver el contexto de nombramiento por defecto para el dominio actual.

Asegúrese de que la máquina en la que está instalado el Servicio del almacén de claves de Sparx Systems pueda contactar el controlador del dominio del directorio activo y tiene los permisos necesarios para consultar el directorio activo del dominio.

No puedo abrir raíz DSE.

El módulo de autenticación del directorio activo falló al iniciarse ya que no puedo abrir la raíz del dominio DSA (Agente del Servidor del Directorio) Entrada Específica (DSE) en ldap://rootDSE. La entrada DSE raíz provee información acerca del contenido y capacidades del controlador del dominio del directorio activo.

Asegúrese de que la máquina en que se instala el Servicio del almacén de claves de Sparx Systems pueda contactar el dominio del directorio activo y tiene los permisos necesarios para consultar el directorio activo del dominio.

No se pudo iniciar la interfaz COM del directorio activo.

El módulo de autenticación del directorio activo falló al iniciarse ya que este no pudo abrir o acceder a la interfaz COM del directorio activo.

Asegúrese de que la máquina que aloja la cuenta del usuario bajo el que se ejecuta el Servicio del almacén de claves de Sparx Systems tiene los permisos necesarios para crear y comunicarse con la interfaz COM del directorio activo.

No permitió el nombre del grupo del DirectorioActivo proporcionado en la propiedad de configuración AUTHMETHOD_OPTIONS.

El módulo de autenticación del directorio activo falló al iniciar ya que la propiedad de configuración AUTHMETHOD_OPTIONS se dejó en blanco.

Ingrese un grupo del directorio activo válido en la propiedad AUTHMETHOD_OPTIONS en el archivo de configuración del servicio. o use el módulo de autenticación AM_GLOBALPASSWORD si no desea que el acceso al almacén de claves se restrinja a un grupo del directorio activo particular.

Grupo [Nombre del grupo] no encontrado.

El módulo de autenticación del directorio activo falló al iniciar ya que el grupo del directorio activo especificado en la propiedad de configuración AUTHMETHOD_OPTIONS no se pudo resolver.

Asegúrese de que el nombre del grupo especificado en la propiedad de configuración AUTHMETHOD_OPTIONS exista y se deletree correctamente.

Usuario [Nombre del usuario] no es un miembro de ningún grupo permitido.

El usuario falló al autenticarse con el almacén de claves ya que no es un miembro del grupo del directorio activo especificado en la propiedad de configuración AUTHMETHOD_OPTIONS.

Agregar el usuario al grupo especificado en la propiedad de configuración AUTHMETHOD_OPTIONS.

Nombre de la cuenta [Nombre del usuario] no encontrada.

El nombre del usuario que requiere autenticarse con el almacén de claves no se pudo encontrarse en el dominio.

Agregar usuario al dominio.